Start-up fails

Home Forums Discovery Server Start-up fails

Tagged: 

This topic contains 2 replies, has 3 voices, and was last updated by  saylormd 7 months, 2 weeks ago.

  • Author
    Posts
  • #13161

    Henrik Schultz
    Participant

    Hi,

    I just bought the (new) Discovery a few days ago. Fired up a couple of days ago while downloading the Essentials app to my Galaxy 8. The app finds the Discovery fine. I go on to Connect, and get the message that the Discovery must update software etc. I click Download and Install. After about 15 minutes of the Discovery downloading etc, I get sent back to the Connect page. I then click Connect again, and the same thing happens. I never get beyong this tedious routine of Downloading and Installing updates.

    When I, on the Connect page in the app simply search for a device, I’m asked to specify an IP adress (which I don’t know). If I go on to click Scan (without specifying an IP adress), the app fails.

    I have, of course, tried to both re-start and re-set the Discovery. But I get the same error.

    This is neither simple plug & paly, nor very impressive. I have contacted my dealer, who refers to the importer. The importer refers to the dealer. I have complained to both, and they tell me it must be an error, and that they will get back to me. I’m still waiting.

    / Henrin 🙁

  • #13202

    jserio2335
    Participant

    Henrin,

    It’s very frustrating and you will still be waiting for a while because customer service for the ELAC Discovery is terrible.

    Joe

  • #13391

    saylormd
    Participant

    There is an answer for this problem. Can’t tell you what it is since it never happened to me. Do not wait for a response via FORUM.
    Instead please send email to

    Customerservice@elac.us
    Attention: Charles Mallari

You must be logged in to reply to this topic.