407 air-x (wireless) – power led does not light up..

Home Forums Line 400 407 air-x (wireless) – power led does not light up..

This topic contains 3 replies, has 2 voices, and was last updated by  jeroenk 11 months ago.

  • Author
    Posts
  • #17477

    jeroenk
    Participant

    Hello,

    On one of my speakers the power led will not light up. I think there is something wrong (I hope not).

    What can I do to examine the cause?

    Eg I cannot find a fuse to check. I checked the power source.

    Kind regards,

    Jeroen

    • This topic was modified 11 months ago by  jeroenk. Reason: Typo
  • #17491

    Charles Mallari
    Moderator

    Hello Jeroen,

    Because of the nature of your problem please contact product support directly.

    For product support within North America contact:

    customerservice@elac.us

    888-541-0996

    Monday – Friday 9am – 5pm PST (Excluding Holidays)

    For product support outside North America contact:

    info@elac.de

    T: +49 0431 / 64774-0

    • #17497

      jeroenk
      Participant

      Ok, thank you. By the way: I found a fuse right under the power plug (rear 407 air-x). I will check that first.

      Kind regards,

      Jeroen – Netherlands.

  • #17502

    jeroenk
    Participant

    Solution: I opened the fuse compartment, the fuses were ok (there were two, I think one spare and one primary), I cleaned them both with alcohol and placed them back -> problem solved.

You must be logged in to reply to this topic.